Monthly Archives: January 2012

IMPORTANT: Update to Mumble 1.2.3a

Due to an expiring certificate no Mumble 1.2.2 or newer released before today (15.01.2012) will work on the Windows Platform after 15 January 2012 11:36:47 GMT. If such an outdated Mumble is launched after that date the error message “A … Continue reading

Posted in News | 14 Comments